Auto-conector de señales

El conector de señales (Auto connector) actúa como un puente entre la plataforma MetaTrader 4/5 y MT2Trading: Este se vincula a su indicador/plantilla, configurado en MetaTrader, y envía sus señales al robot, el cual las colocará en tu cuenta, de manera automática.

¿Cómo se carga en Metatrader 4?

Para lograr cargar los archivos de MT2 Trading en su plataforma MetaTrader exitosamente, debe copiar y pegar o arrastrar tanto los indicadores como librerias que incluye la carpeta MT2Trading.


En primer lugar, debe ocuparse de los archivos Indicadores.

  1. Localizar archivo del conector «MT2Trading_Auto.ex4/ex5» dentro de la carpeta: «MT2Trading -MetaTrader > MT4/MT5 > MQL4 / MQL5 > Indicators».
  2. Copiar el archivo del conector «MT2Trading_Auto.ex4/ex5».
  3. Pegar en nuestra plataforma MetaTrader, para esto debemos ir a: «Archivo > Abrir Carpeta de Datos > MQL4 > Indicators».

El conector (archivo: MT2Trading_Auto.ex4) puede encontrarlo en el archivo de descarga del bot MT2, dentro de la carpeta «Indicators».

En segundo lugar, debe ocuparse de los archivos Librerias.

  1. Localizar archivo de la libreria«mt2trading_library.ex4/ex5» dentro de la carpeta: «MT2Trading -MetaTrader > MT4/MT5 > MQL4 / MQL5 > Libraries».
  2. Copiar el archivo de la libreria«mt2trading_library.ex4/ex5″».
  3. Pegar en su plataforma MetaTrader, para esto debe ir a: «Archivo > Abrir Carpeta de Datos > MQL4 > Libraries».

¿Cómo se abre en MetaTrader?

Una vez que tengamos el archivo del conector dentro de nuestras carpetas de MetaTrader, vamos a proceder a abrirlo sobre un grafico.

  1. Abrir un nuevo grafico y elegir la temporalidad con la que vamos a trabajar.
  2. Abrir el navegador: Presionando CTRL + N.
  3. Arrastrar el indicador de señales que vamos a utilizar a nuestro grafico (en los archivos de descarga de MT2 incluimos el indicador «BinaryProfit» como cortesia, en caso de que no tengan uno con cual trabajar).
  4. Arrastrar el archivo del conector «MT2_Connector» hacia el grafico.

Una vez que arrastres tu indicador y conector hacia el gráfico correctamente, te encontrarás con la configuración del conector, que se ve así:

Parámetros configurables

1. Nombre del indicador

El nombre del indicador se usa para identificar de donde vendran las señales que seran colocadas en su cuentra y para mostrar los nombres de las mismas en la tabla de operaciones. Las estadisticas y el historial de transacciones tambien se basan y ordenan segun los nombres de las señales.

Una vez que arrastre el conector a su grafico con un indicador, solo debera darle click en la flechita del costado y se mostraran todos los indicadores en el grafico, disponibles para ser utilizados.

En este caso utilizaremos el indicador «BinaryProfit» como ejemplo. Recuerde que puede utilizar cualquier indicador que desee.

Como puede ver, las señales provenientes del indicador se mostraran con el nombre del mismo en la tabla de operaciones dentro de la plataforma MT2.

2. Up # (buffer de señal)

Cada indicador de Opciones Binarias que genera señales en forma de flechas, puntos u otros signos gráficos, transmite los datos de la señal en los denominados búferes de indicadores.

Una vez que el conector identifica el indicador de señales, automaticamente leera las flechas o puntos del mismo y le dara la opcion de configurar los buferes para que el robot coloque operaciones de Compra o Venta por usted.

En el buffer «Up» (arriba) debe seleccionar cual recurso grafico es el que le indicara al robot abrir una operacion de COMPRA en su cuenta.

En este ejemplo, puede ver como seleccionamos la flecha verde hacia arriba para que el robot identifique como operaciones de COMPRA.

3. Down # (buffer de señal)

Al contrario que el buffer Up (arriba), el buffer Down (abajo) sera el encargado de identificar las formas de señales su indicador en su grafico y abrir operaciones de VENTA por usted en su cuenta.

En este ejemplo, puede ver como seleccionamos la flecha roja hacia abajo para que el robot identifique como operaciones de VENTA.

4. Tipo de Entrada (Entry Type)

Una vez configurados los buferes de señales, podra elegir entre dos tipos de entradas: en la nueva barra (OnNewBar) o intrabarra (IntraBar).

En la nueva barra la operación se realizara al cierre de la barra de la vela en la que recibio la señal (es decir, en la apertura de la nueva barra).

La entrada intrabarra significa que la operacion debe realizarse inmediatamente cuando aparece la señal.

¿Qué tipo de entrada debe usar dependiendo del indicador?

La mayoría de los indicadores de reversa generan señales para ingresar en la nueva barra, mientras que los indicadores de tendencia generan comúnmente señales para la entrada intrabarra.

5. Monto de Operacion (Trading Amount)

En este parametro podra especificar el monto de cada operacion que realizará el robot en su cuenta.

Si quisiera cambiar el monto de cada operación solo debe modificar este parámetro.

Por ejemplo: Para 5$ USD, deberia escribir «5.0». Para 10$ USD deberia escribir «10.0», y asi consecutivamente…

6. Tiempo de Expiracion (Expiry Time)

En este parámetro podrá especificar la temporalidad de sus operaciones.

En el ejemplo, podemos ver que la expiracion está configurada en «5». Esto significa que cada operacion que abra el robot, se cerrará automaticamente 5 minutos luego de ser colocada.

Si quisiera temporalidades mayores o menores, solo debe modificar este número.

7. Martingala (Martingale)

Por defecto la configuracion de estrategia de Martingala viene apagada.

Para activarla abra el menu donde dice «No Martingale» y elija su estrategia deseada.

Puedes aprender todo sobre la estrategia Martingala clickeando aquí

8. Broker

Por ultimo, debera seleccionar en que broker/s quiere que su robot coloque las operaciones provenientes de su indicador.


Por defecto, viene seleccionado «All» refiriendose a que las operaciones se colocaran en todos los brokers (siempre y cuando tenga cuentas de esos brokers abiertos en MT2 Trading)

Para modificar este parametro y elegir su broker solo debe seguir los siguientes pasos:

  1. En MetaTrader, dirigirse en el menu superior a ««Graficos > Lista de Indicadores > click en MT2trading_auto»> Editar».
  2. Click en «Parametros de entrada > Select broker > click en la flecha hacia abajo para abrir el menu»
  3. Seleccionar su broker de preferencia y darle click a «Ok»

Si ha conectado su indicador correctamente, debería ver una ventana igual a esta en su grafico.

Para deshabilitar temporalmente el conector, puede darle click en el boton «Pausa» y su robot dejara de operar.

Para volver a habilitarlo, solo es necesario darle click al boton «Iniciar» nuevamente y su robot continuara con la operativa.